Welcome Guest! To enable all features please Login or Register.
Options
Go to last post Go to first unread
kinnunen.ilkka@gmail.com  
#1 Posted : Thursday, March 28, 2019 9:27:52 PM(UTC)
kinnunen.ilkka@gmail.com

Rank: Newbie

Groups: Registered
Joined: 4/19/2017(UTC)
Posts: 1

1. When downloading the program for controller device max using software embryo version 2.2.4.1
The program works in monitoring mode but when I send the program to the device, some of the functions do not work.
for example, the port specified in the program 13
2. I'll control my program propotional hydraulic valve and it needs a frequency of about 110hz controlled by a joustic handle.
EmbrioAdmin  
#2 Posted : Friday, March 29, 2019 9:46:00 AM(UTC)
EmbrioAdmin

Rank: Administration

Groups: Administrators
Joined: 12/11/2014(UTC)
Posts: 639

Thanks: 1 times
Was thanked: 36 time(s) in 33 post(s)
1. In what way isn't it working? Are you getting any error messages in the message log at the bottom of the screen?

I did find recently that there was an error in the timing program, which gets uploaded before the final program. It might look like the final program is uploaded and failing, when it is actually the timing program. On the bottom detail toolbar, can you go to the Profiler tab and uncheck the "All nodes must have timing data to upload" checkbox and try uploading the final program again? If that doesn't solve your problem, can you zip up the entire project folder and send it to me at ezra@embrio.io so I can take a look?

2. Each agent can run at a different refresh rate. You should have an agent with a node controlling your valve and set the refresh rate to 128. Is that close enough to 110? Refresh rates in Embrio are all base 2 due to the way the final program is compiled.
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error