Welcome Guest! To enable all features please Login or Register.
Options
Go to last post Go to first unread
unicenter  
#1 Posted : Monday, March 16, 2015 1:35:21 PM(UTC)
unicenter

Rank: Newbie

Groups: Registered
Joined: 3/11/2015(UTC)
Posts: 6

Thanks: 1 times
I am using Arduino 1.6.1 with Embrio. When I upload the code to the Arduino there is quite a long delay while the Arduino IDE environment loads. Is there a technique where I can open the IDE or something else that will mean it doesn't have to load on each occasion that you upload code? It seems to automatically close after the code has been uploaded.
EmbrioAdmin  
#2 Posted : Monday, March 16, 2015 2:00:16 PM(UTC)
EmbrioAdmin

Rank: Administration

Groups: Administrators
Joined: 12/11/2014(UTC)
Posts: 661

Thanks: 1 times
Was thanked: 36 time(s) in 33 post(s)
It uses the command line functionality exposed with the new version of Arduino, it basically just opens a command prompt and calls the build command. I don't think the IDE is opening, and I haven't found a way to hide that Arduino pop-up, but I'm not exactly sure what it's doing after the command is called. I'm not sure if there's anything I can do about that or the upload speed. I'll compare to uploading right through the IDE and if it's different try to figure out why.
unicenter  
#3 Posted : Monday, March 16, 2015 2:37:57 PM(UTC)
unicenter

Rank: Newbie

Groups: Registered
Joined: 3/11/2015(UTC)
Posts: 6

Thanks: 1 times
It might be useful to have some kind of graphic that shows on screen to animate the connecting to Arudino, uploading code and completed.

I am happy with having a little button and understanding what is going on but I think the user base that will use your product would be happier with some kind of in your face visual confirmation. Will also distract them from the amount of time that it takes.

Maybe moving the button from the bottom to more prominent position at the top of the bar like in the Arduino IDE might help.
EmbrioAdmin  
#4 Posted : Monday, March 16, 2015 3:00:42 PM(UTC)
EmbrioAdmin

Rank: Administration

Groups: Administrators
Joined: 12/11/2014(UTC)
Posts: 661

Thanks: 1 times
Was thanked: 36 time(s) in 33 post(s)
Yeah maybe that should go in the top bar, there is a lot of room up there. It could even use that actual timing of the last upload so it would have at least some idea how long it'll take. I'm hoping to figure out a way to hide that Arduino popup too, it's a bit jarring.
unicenter  
#5 Posted : Monday, March 16, 2015 3:52:47 PM(UTC)
unicenter

Rank: Newbie

Groups: Registered
Joined: 3/11/2015(UTC)
Posts: 6

Thanks: 1 times
Well.......if you happened to overwrite the graphic with the Embrio logo ;)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error